update flash to avoid hacker disaster

image

Adobe has just announced a critical update to Flash Player. My suggestion? Update. Do it now.

From Adobe: “These updates address a critical vulnerability that could potentially allow an attacker to remotely take control of the affected system.”

From PCWorld: “Adobe released an update for Flash Player to fix a critical remote code execution vulnerability that is actively being targeted by attackers.”

Apple apparently is disabling older versions of the plug-in and forcing users to upgrade to the current version of Flash to avoid the issue. However, I haven’t experienced this “forced” upgrade today and had to upgrade manually.

The big lesson: UPDATE YOUR SOFTWARE, PEOPLE. Please and thank you.